
This ReadMe file contains information on the Arabesque Ecco Simplicity  Demo that may not be
in the on-line help.
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1.  INSTALLATION  AND TROUBLESHOOTING
======================================================

The Arabesque installer requires Windows 3.1 or Windows for Workgroups® to be on your path
in the format <drive:>\<directory>. To determine if Windows is on your path, type PATH at the
DOS prompt. If the Windows directory is not on your current path (or not in the proper format),
you can temporarily set it by typing "SET PATH = <drive:>\<Windows directory>" at the DOS
prompt. If Windows is on your C:\ drive in a Windows subdirectory, you would type
SET PATH=C:\WINDOWS.  Reboot your computer after installing Ecco to restore your original
PATH. Do not use the Windows DOS box, as errors may occur.  The Arabesque installer also
requires approximately 65K of space in the Windows subdirectory.

To Install Arabesque Ecco:

1. Start Windows 3.1 or Windows for Workgroups.
2. In the Program Manager, from the File menu select  "Run" and type A:\SETUP.EXE (if you are
using a different drive and directory location, type y:\xyz\SETUP.EXE, where y: is the drive you
are installing from and \xyz\  is the directory path to the file.)
3. Ecco installs into the directory specified. If the directory does not exist, one will be created.
4. A new program group titled "Arabesque Ecco" will be created.
5. A subdirectory named "TEMPLATE" is created. The template files, SALES.ECT, LEGAL.ECT,
MANAGER.ECT, PROJECT.ECT and RESEARCH.ECT are stored there. Finally, the Program
Manager icons for the Ecco program, the Ecco Quick Tour, and this README file are created in
the Arabesque Program Group.  You may double-click the QuickTour icon in the Ecco program
group to see an overview of Ecco, or choose OVERVIEW from the Help Menu in Ecco.

WARNING: If you are re-installing Ecco and are installing into the same Ecco directory, any
existing Arabesque templates will be overwritten including DEFAULT.ECT. If you have such Ecco
templates on your system that you have modified and wish to save, remember to rename your
template files or move them to a different directory prior to installing Ecco.

If You Can't Install:
If you find you can't install using the Arabesque Ecco Installer, try these things:
1. Make sure Windows is on your PATH. (See above)



2. Make sure you have enough hard disk space.
3. Disable any Windows shells such as Norton Desktop or  PC Tools. If you are  installing to a
drive other than C: and are getting the error message "Cannot install to C:" please check that you
have 65K of available disk space and have write access in your Windows Directory.

If you need additional help with this demo you can contact Arabesque Software via our
CompuServe Forum  (type GO ECCO) or our BBS system at (206) 881-0905.  We highly
recommend CompuServe because of the great breadth of response available there. Technical
notes and tips are available on both the CompuServe forum and the Arabesque BBS.

2. FILES INSTALLED
=======================================================
Below is a list of files installed to your hard drive during a full installation of the Arabesque Ecco
Demo.  This list is provided for your reference only.

File name Where installed...
___________________________________________________________
Text files

IMPORT.WRI your local Ecco directory
README.WRI your local Ecco directory

Templates
DEFAULT.ECT your local Ecco directory
MANAGER.ECT the template directory within your local Ecco directory
LEGAL.ECT the template directory within your local Ecco directory
SALES.ECT the template directory within your local Ecco directory
RESEARCH.ECT the template directory within your local Ecco directory
PROJECT .ECT the template directory within your local Ecco directory

Help files
SLIDES.HLP your local Ecco directory

Configuration
ECCO.CFG* your Microsoft Windows directory
ECCO.ALM* your Microsoft Windows directory
ECCO.FDB* your Microsoft Windows directory

Application
ECCO.EXE your local Ecco directory

*  ECCO.CFG stores information about your user preferences and ToolBar settings etc.
The ECCO.FDB and ECCO.ALM files store info about local Ecco files and alarm information
respectively and are not a part of installation, but are created subsequently in your Windows
directory by Ecco once you have run the program.

3.  HELP
=======================================================

Ecco ships with a state-of-the-art online help system that contains the entire User's Guide, fully
indexed and cross-referenced with a complete glossary. To obtain a copy of this help file for use
with your demo, you can download ECOHLP.EXE from our CompuServe forum (type GO
ECCO) or our BBS system at (206) 881-0905.  This file is a self extracting compressed file.  Type
ECOHLP.EXE at a DOS prompt in the directory where you downloaded the file.  It will extract the 
ECCO.HLP file, which should then be placed in your ECCO directory.



For a quick overview of Ecco features, from the Help menu choose "Overview". For context-
sensitive help at any time, choose F1 or click on the yellow "?" button in the top right corner of 
any
dialog.

For help on the menu commands, from the Help menu choose "Menu Help".  Your cursor will
change to an arrow  with the text "Choose Menu" below it.  You may then  select the menu for
which help is desired.

For help on your active view choose "Help on this View" from the Help menu.

4.  TEMPLATES ARE INCLUDED
=======================================================

Ecco templates have the extension ".ECT" and can be  opened directly from the File menu's
Open... dialog by selecting "Ecco Templates (*.ECT)" from the "List Files of Type" drop-down list
in the lower left of the dialog.

When the File command "New" is chosen, a new document is created based on the template file
"DEFAULT.ECT". This template file can be modified like any other template to provide custom
new file creation for specialized applications (for example, default, views, and so on, for
department standardization).  Holding down the shift or control key while selecting "New" will
avoid the use of this template.

5. USING THE SHOOTER TO SEND NAME, ADDRESS, AND PHONE NUMBERS
=======================================================

If one or more names are selected in the PhoneBook (and  neither outline notes nor a character
range are selected),  Shooter will shoot the name and address information (and  optionally the
phone numbers) for all selected names. The information will be sent in a letter head format.
However, if any outline notes are selected, then only names and  their subordinate outline text will
be included when shooting, and no addresses or phone numbers will be sent.

When Shooting from the PhoneBook, you are prompted to  make a choice of which (if any) phone
numbers to send  along with the name and/or address.  You are prompted  in a like manner when
using the Copy button in the  PhoneBook form.

6. SHOOTER COMPATIBILITY
=======================================================

If the Shooter is unable to locate the Edit menu when using it in conjunction with the current
application, the  user will be prompted for Copy/Paste keyboard options.   Some applications do
not respond to standard Copy/Paste  actions which can cause problems for the Ecco Shooter.   In
these cases you can add entries to the Ecco section  of your WIN.INI which will enable the
Shooter.  For  applications which do not have keyboard shortcuts make  the following entry
<application name>=101.  For  applications which make use of  CTRL + C/V use  <application
name>=202.  For applications which make  use of  CTRL + INS/Shift + INS use <application
name>=303.  For example, WinCIS requires the use of the  CTRL + INS/Shift + INS keys, so the
entry in your WIN.INI would  look like this:
[ECCO]
WINCIS.EXE=303



7.  PREFERENCES ADDITIONS
=======================================================

Ecco makes automatic backups for you.  The default  configuration is currently set to create a
backup copy of  new files on file close, with 2 rotating backups.  "Auto-Save on File Close" is
selected and automatic file  saving is set to 10 minute increments.  These defaults  are set in
Preferences under the Tool menu.

You can specify your own keyboard shortcut for  activating the Shooter. When used with the Ctrl
+ Alt  keys, this will activate the Shooter in any Windows  application, as long as Ecco is running.
For more  information about the Shooter, please refer to the Ecco  User Guide or on-line help.

To show major holidays for the United States, United  Kingdom, Canada (French and English),
Australia,  France, Germany, Italy, Israel, Spain and Sweden when  in the Calendar view, choose
the desired country in the  "Show Holidays for" drop down list. Ecco defaults to  the country
chosen in the Windows Control Panel and  will change the displayed holidays to match your
Control Panel setting until you specifically choose  another country via Preferences.

8.  PRINTING
=======================================================

Page Sizes

In Calendar and PhoneBook view, page sizes for most  DayTimer , Franklin  and other popular
day  planners are now available.  Also, Ecco supports A4, A5, Legal and Executive paper sizes. In
the PhoneBook, many US and UK Avery mailing label sizes are available.

Calendar

In Calendar view, the user name you specified during  installation will print in the upper left corner
of the  calendar and the time period in the upper right corner.  The user name can be changed in
the Preferences dialog  box.

When printing the Calendar month grid, if there are  more appointments than will fit in the space
for the  specified date, a plus sign will be printed after the last appointment shown.

PhoneBook

In the PhoneBook view, grid lines print between  phonebook entries. If the phone number
columns won't  fit on the specified page size, these numbers will be  stacked and right aligned.

To print salutations (Mr., Ms., Dr., etc.), in the PhoneBook view, choose name, address format 
and
in the Options.. dialog, check "Switch Lastname, Firstname to Firstname, Lastname".

9.  DISK COMPRESSION SLOWS DOWN FILE SAVE/FILE OPEN
=======================================================

Users of DblSpace, Stacker or other similar real-time  disk compression utilities may experience
longer file  save times than normal. For large file the difference  can be as great as 10 times (for
example, the time to  save a given file can go from 3 seconds to 30 seconds). These utilities
defeat Ecco's significant, performance optimizations for large files.  We recommend that you
place your  Ecco files in a non-compressed partition.



10.  COMPATIBILITY
=======================================================

While every effort has been made to make Ecco  compatible with all major hardware and
software, there  are some specific situations you should be aware of.

Video Drivers
If you are using an ATI Ultra Video driver dated before  June 1993, you may encounter conflicts
with Ecco. There  are known problems accessing disabled cascading menus  when using the
640x480 VGA, 600x800 SuperVGA or 1024x768 with Small Fonts. These problems are believed
to be specific to this driver. ATI is releasing a new  driver that will fix these problems.

Modems
If you experience problems communicating with your  modem when dialing from the PhoneBook,
you can add an  adjustable delay following the dial command.  Add the  following entry to the
Ecco section of your WIN.INI  file:
[ECCO]
delayAfterDialing=n
N should be an integer between 0 and 250 and represents  the number of milliseconds of delay
after dialing.

If you still have problems dialing from Ecco, please run the Microsoft Diagnostics Program
(MSD.EXE). To run MSD, at the DOS prompt, change to your Windows directory and type MSD.
At the MSD main menu, choose "File..." "Print Reports". In the Print Reports dialog, check system
summary, COM ports and IRQ Status. Print the report and contact Arabesque Customer Support
at (206) 885-0559.

cc:Mail
Applications developed for use in the cc:Mail  environment require the existence of the cc:Mail
VIM,  SMI and Mail Engine components for the appropriate  platform. Users of the following
cc:Mail products will  already have the required files:  cc:Mail for Windows  v. 2.0 or greater,
cc:Mail for OS/2, WPS v. 1.0 or greater

These files must be installed in the Windows directory  for correct performance.

Users of versions of cc:Mail prior to the above  products will need to obtain the cc:VIM Runtime
product  directly from cc:Mail in one of the following ways:   Contact cc:Mail Support directly,
Download from the  cc:Mail Bulletin board the ZIP files containing the VIM  files, Download from
CompuServe from the LOTUSB forum

11.  PERFORMANCE
=======================================================

Ecco is a RAM-based program. Running in Windows 386  Enhanced Mode should provide you
with plenty of RAM  memory to run very large Ecco files. If you experience  slow performance,
make sure you are running in 386  Enhanced Mode. You can determine this by selecting  "About
Program Manager" from the Help menu in the  Program Manager menu bar.

System Resources and GDI. Ecco takes advantage of  Windows' Graphical Device Interface
(GDI) to allow  multiple windowing and to define many views in Ecco.  Having more than 25 views
open in Windows will effect  available GDI system resources. For best performance,  keep only
the necessary views open within Ecco.

Networks.  Customers who are using a peer to peer  network (such as Windows for Workgroups)



may need to  adjust the interval at which Ecco updates local files  which are attached to a group
file. Using any text  editor, (e.g. Notepad) open WIN.INI and search for the  [Ecco] section. Edit
the line: glExLogDelay=3000 to  glExLogDelay=5000. Save the changes, and exit your text  
editor.

If you are using Novell Netware, you may see better  group performance if you decrease the
setting. Values  below 500 or above 10000 are not recommended. It is  advisable for all systems
on the network to use the  same setting.

12.  USING *.WAV FILES WITH ALARMS
======================================================

*.WAV files are Windows 3.1 sound files that Ecco can run with Alarms if a third party sound
driver is installed.

In order to use *.WAV files, you must have a Windows 3.1 sound driver capable of running
these files. Most MIDI drivers such as those provided with SoundBlaster , or other sound
systems will run *.WAV files. If you do not have these available, you can download
SPEAKER.DRV from CompuServe in the MIDI forum (GO MIDIFORUM).

To install a device driver, run the Windows Control Panel and double click on the "Drivers" icon.
click on the "Add" button to add the driver.  For more information on installing device drivers, see
"Installing and Removing Drivers" in your Microsoft Windows documentation.

IMPORTANT: You must have "enable system sounds" checked in the Sound section of Windows
Control Panel in order to hear Ecco alarm alerts. This is the Windows default setting.

13.  AUTO-DIALING USING MODEMS LESS THAN 9600 BAUD
=======================================================

If you intend to use Ecco's auto-dialing feature with a modem operating at less than 9600 baud,
you should be aware that Windows defaults to setting each of your computer's communications
ports to a speed of 9600. Attempting to auto-dial with a less than 9600 baud modem will not
succeed until you have set the communication port's baud rate to match your modem's baud rate.

To set your communication port to the baud rate matching your modem, open the Windows
Control Panel accessory and choose Ports. Select the COM port to which your modem is
attached and set the baud rate appropriately.

====================================================
Thank you for trying Arabesque Ecco!

END OF README.WRI
====================================================


